What technology is required to use Kaboodle?

by admin

The only technology you need is a modern web browser. Kaboodle is built in Azure and utilises Office 365. A valid E1 or higher subscription is required to use all of the functionality within Kaboodle.

  • Posted in
  • Comments Off on What technology is required to use Kaboodle?